Display Issues with NPS Gauge in Analyze

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 15:23 PDT

Update

We are continuing to investigate this issue.
Posted Jun 04, 2026 - 11:54 PDT

Investigating

⚠️ We're aware of an issue impacting how our NPS questions displays on the Analyze page, and we are investigating the cause.
Posted Jun 04, 2026 - 11:53 PDT
This incident affected: SurveyMonkey.