Error when accessing the Collect page

Incident Report for SurveyMonkey

Resolved

This issue is now resolved
Posted May 14, 2025 - 08:54 PDT

Identified

An error is showing when accessing the Collector page for surveys that don't have any collectors. We have identified the cause of this issue and we are currently working on a solution.
Posted May 14, 2025 - 08:38 PDT
This incident affected: SurveyMonkey.