SurveyMonkey Rewards - Unable to cash out rewards for Amazon gift cards

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Feb 28, 2026 - 09:24 PST

Identified

The SurveyMonkey Rewards Amazon gift card cash out option is not working. We have identified the cause of this issue and we are working on implementing a fix. The Prizeout cash out option is still available and Amazon gift cards are available on Prizeout's platform.
Posted Feb 26, 2026 - 02:18 PST
This incident affected: SurveyMonkey.