App listing cannot be updated on SurveyMonkey

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 07:19 PDT

Identified

We are currently investigating an issue preventing users in all regions from updating their App listing on the Developer portal of SurveyMonkey.
Posted Apr 24, 2026 - 05:19 PDT
This incident affected: SurveyMonkey.