SurveyMonkey 'Home' page unavailable for US/CA customers

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 07:04 PDT

Investigating

The SurveyMonkey homepage is currently inaccessible for some regions. Our team is actively investigating the issue to resolve it as quickly as possible. Thank you for your patience!
Posted Jul 06, 2026 - 05:33 PDT
This incident affected: SurveyMonkey.