Login prompts appearing on Help Center pages for logged-in users on the EU data center

Incident Report for SurveyMonkey

Resolved

This issue has been resolved and EU customers should now be able to log in on Help Center pages.
Posted Nov 11, 2024 - 15:14 PST

Investigating

The Help Center and contact flow pages are currently prompting customers logged in to an account on the European Data Center to log in. For those impacted, you can still contact support via the logged-out options on the help center while this issue is being investigated, and you can also contact the support team directly by emailing support@surveymonkey.com from the email address associated with your account.
Posted Nov 06, 2024 - 16:47 PST