Cannot Connect to Microsoft Excel in Connect Apps

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 06:59 PDT

Identified

There currently is an issue where users cannot connect to Microsoft Excel in Connect apps. We believe this issue also impacts the integration for users who have previously connected to Microsoft Excel in Connect apps. We're working on a resolution.
Posted Aug 12, 2025 - 20:50 PDT
This incident affected: SurveyMonkey.