New Users on Basic Plans cannot buy responses and checkout for MaxDiff Solution Surveys

Incident Report for SurveyMonkey

Resolved

This issue is now resolved.
Posted May 15, 2025 - 06:07 PDT

Identified

The issue has been identified but the team is still working on finding the best resolution.
Posted May 14, 2025 - 12:27 PDT

Investigating

We are currently investigating this issue.
Posted May 14, 2025 - 05:15 PDT
This incident affected: SurveyMonkey.