My Team: Manage Users→User→Manage Surveys page not loading for admins
Incident Report for SurveyMonkey
Resolved
The issue is now resolved.
Posted Oct 01, 2024 - 14:25 PDT
Investigating
⚠️ We're aware of an issue impacting the My Teams feature on our Enterprise Plan, and we are investigating the cause.
Posted Oct 01, 2024 - 14:06 PDT
This incident affected: SurveyMonkey.