SurveyMonkey Help Center is Down

Incident Report for SurveyMonkey

Resolved

This incident has been resolved. Help Center should load normally.
Posted May 27, 2026 - 22:13 PDT

Monitoring

Help Center should be loading now. We're monitoring.
Posted May 27, 2026 - 22:09 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 27, 2026 - 22:05 PDT

Investigating

SurveyMonkey's Help Center (https://help.surveymonkey.com/) is currently down for most users.
Posted May 27, 2026 - 22:03 PDT
This incident affected: SurveyMonkey.